AWC 500 PCM5.2 software bundle (CODESYS SP15 Patch 20)

AWC 500 PCM5.2 software bundle (CODESYS SP15 Patch 20)

You have chosen to download our software.

Within a few seconds, you will receive an email containing a download link.

Having trouble using the software? Please contact support@deif.com. 

Best regards, 

DEIF A/S

The software is subject to copyright DEIF A/S
By following the above mentioned link and downloading the file you automatically accept DEIF A/S copyright and license agreement (EULA). The license agreement can be found on www.deif.com/software

3.0.6.0

Fixed:

- https supports more secure methods with openssl 1.1.1k.
- Web interface: CODESYS webvisu detection failed after change to https.
- Memory free information in web interface and REST API now includes buffers and cached memory.
- Updated ethercatio to v1.1.4.1.
- Fixed mutex handling when using UART with IFM5.1 and IFM6.1.
- OE-Lite updated to continue to build as github no longer accepts http. This also causes changes to some of the package versions.

Added:

- Added gdb to the controller.
- Added backup/restore feature to web interface.
- nginx currently not configured and not started by default. Beware that applications may leave persistent config in /app/nginx.
- Added HID and HIDRAW configuration to the kernel, which are need for CODESYS Key (USB dongle).
- Added dedicated worker thread to solve low latency.
- Added `appmode` support to get the current status.

Changed:

- Openssl updated to version 1.1.1k.
- Added Windows SDK again since it contains tools for bootstrapping use in production.
- An empty /data/sysconf/ethercat file can be used to prevent EtherCAT master operation.
- SCP protocol support in OpenSSH removed. Users will have to use SFTP protocol instead.
- The vsftpd server will only be started automatically if configured with custom /data/sysconf/vsftpd.conf file.

Security:

- Updated Vue.js and jQuery components to fix various security issues.
- Updated OpenSSH to fix various security issues, including CVE-2020-14145.
- Updated OpenSSL to fix various security issues, including CVE-2022-0778.
- Updated lighttpd to fix various security issues, including CVE-2008-0983, CVE-2018-19052 and CVE-2019-11072.
- Updated busybox to fix various security issues.
- Lighttpd configuration changed to set X-Frame-Options HTTP header to protect against "clickjacking" attacks.
- Lighttpd configuration changed to set X-Content-Type-Options HTTP header to protect against MIME-sniffing on the response body.

 

3.0.6.0

27.01.2023

Fixed:

- https supports more secure methods with openssl 1.1.1k.
- Web interface: CODESYS webvisu detection failed after change to https.
- Memory free information in web interface and REST API now includes buffers and cached memory.
- Updated ethercatio to v1.1.4.1.
- Fixed mutex handling when using UART with IFM5.1 and IFM6.1.
- OE-Lite updated to continue to build as github no longer accepts http. This also causes changes to some of the package versions.

Added:

- Added gdb to the controller.
- Added backup/restore feature to web interface.
- nginx currently not configured and not started by default. Beware that applications may leave persistent config in /app/nginx.
- Added HID and HIDRAW configuration to the kernel, which are need for CODESYS Key (USB dongle).
- Added dedicated worker thread to solve low latency.
- Added `appmode` support to get the current status.

Changed:

- Openssl updated to version 1.1.1k.
- Added Windows SDK again since it contains tools for bootstrapping use in production.
- An empty /data/sysconf/ethercat file can be used to prevent EtherCAT master operation.
- SCP protocol support in OpenSSH removed. Users will have to use SFTP protocol instead.
- The vsftpd server will only be started automatically if configured with custom /data/sysconf/vsftpd.conf file.

Security:

- Updated Vue.js and jQuery components to fix various security issues.
- Updated OpenSSH to fix various security issues, including CVE-2020-14145.
- Updated OpenSSL to fix various security issues, including CVE-2022-0778.
- Updated lighttpd to fix various security issues, including CVE-2008-0983, CVE-2018-19052 and CVE-2019-11072.
- Updated busybox to fix various security issues.
- Lighttpd configuration changed to set X-Frame-Options HTTP header to protect against "clickjacking" attacks.
- Lighttpd configuration changed to set X-Content-Type-Options HTTP header to protect against MIME-sniffing on the response body.

 

Auf dieser Seite können Sie Software-Updates für Ihr(e) Produkt(e) herunterladen und sich verschiedene Utility-Tools und Add-ons beschaffen, die Ihnen beim Einrichten und Konfigurieren Ihres Produkts/Ihrer Produkte sowie bei der entsprechenden Fehlersuche behilflich sein können.

Beachten Sie bitte, dass nicht alle unsere Produkte vom Benutzer aktualisiert werden können. Es werden auch nicht alle unsere Produkte mit einem Utility-Tool geliefert. Somit kann die Liste auf dieser Seite nicht als Übersicht unseres kompletten Produktsortiments angesehen werden.

DEIF registriert Ihren Download zusammen mit der verwendeten E-Mail-Adresse, um Ihnen auf Anfrage Informationen zu künftigen Updates zuzusenden.

DEIF kann nicht für die Folgen fehlgeschlagener Produkt-Updates oder die Nutzung von Utility-Tools haftbar gemacht werden. Auch haftet DEIF A/S nicht für die Folgen einer Verhaltensänderung von Produkten aufgrund eines Software-Upgrades. Es obliegt stets dem Anwender, vor der Inbetriebnahme die korrekte Einrichtung und Konfiguration sicherzustellen. Sehen Sie sich vor der Aktualisierung des Produkts das Versionsprotokoll der Software an.

Lizenzvereinbarung für den Software-Download von www.deif.com

Heruntergeladene Software bleibt Eigentum von DEIF. Die Software wurde möglicherweise nicht für gewerbliche Zwecke ausgegeben, sie wurde vollständig oder partiell geändert oder wiederverwendet oder sie wurde an jedwede Drittanbieter verkauft.Auf dieser Seite können Sie Software-Updates für Ihr(e) Produkt(e) herunterladen und sich verschiedene Utility-Tools und Add-ons beschaffen, die Ihnen beim Einrichten und Konfigurieren Ihres Produkts/Ihrer Produkte sowie bei der entsprechenden Fehlersuche behilflich sein können. 

Die aktuellste Version für volle Funktionalität

Wir empfehlen Ihnen, die von uns bereitgestellten Updates zu installieren, um so das volle Potenzial Ihres DEIF-Produkts nutzen zu können.

Die gesamte optimierte Software kann nach Belieben unter www.deif.com heruntergeladen werden. Navigieren Sie dazu zu „Software“ und dann zu „Software-Download“.

Bei Fragen oder Problemen beim Auffinden der entsprechenden Software für Ihr Produkt wenden Sie sich telefonisch unter der Rufnummer +45 96149614 an DEIF A/S oder an die jeweilige lokale DEIF-Niederlassung. Alternativ können Sie uns auch eine E-Mail an support@deif.com senden. Wir helfen Ihnen gerne weiter.

Press release, June 2015

Information on product improvement specifically related to “older” DEIF A/S ML-2 products.